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1. Introduction
Thank you for selecting CuteDCPTools as your Digital Cinema mastering station
This guide will help you to re-master an existing DCP (Digital Cinema Package), using the
CuteDCPTools DCP mastering plug-in for Adobe After Effects.
Here are some examples what you can do with CuteDCPTools:
• Import a DCP
• Import an encrypted DCP using DKDM or a Key Storage File
• Update the content titles by using the built in TitleHelper tool
• Adding new reels
• Split the DCP into reels
• Updating audio and video tracks without doing any encodings
• Create new compositions with language adaptions, subtitles, close captions or audio
• Import subtitles (SMPTE or Cinecanvas)
• Import Close Captions (SMPTE or Cinecanvas)
• Export subtitles (SMPTE or Cinecanvas)
• Export Close Captions (SMPTE or Cinecanvas)
• Imported subtitles or close captions can be edited and re-timed.
• Sign the DCP
• Encrypt the DCP
• Unencrypt a DCP
• RePackage and export the modified DCP.
• Rewrap wav files to an mxf file from the timeline
The Demo version is fully functional and has a 2 x 15 day trial period.

System requirements
Operating system:
Windows 7, Windows 8 and Windows 10
MacOSX: 10.6 or later
Software:
Adobe After Effects CS6 or later

3

2. What is a DCP?
DCP is the acronym for “digital cinema package” and you can say that is a digital film print
A DCP is not a file format and it is not a single file, instead it is a collection of files and these files are
xml-files and mxf-files. The xml files describes how the DCP should be ingested and also how the
image, audio and subtitle files should be played.
The mxf files is the moving content, i.e. image, audio, timed text, subtitles
A DCP can play image and audio files, like music songs in a playlist.
In a DCP that is called reels and is a part of a composition.
To make it even more complex, a DCP can contain one or many composition(s) and each composition
can contain one or many reels.
One or many composition playlist(s) from the DCP could be ingested into the cinema server.
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3. Installation of CuteDCPTools
It will only take a few minutes to install CuteDCPTools.
You can download the latest version of CuteDCPTools from the Fandev website: http://www.fandev.com
Windows: If you have already installed a previous version, go to the control panel and uninstall the
older version.
Double-click on the executable setup file downloaded from the Fandev website and follow the on-screen
instructions.
Mac: Double-click on the downloaded installer, the installer will guide you through the installation.

Windows installation dialog

Mac installation

CuteDCPTools consists of two plug-ins: CuteDCPTools.aex and MXF_DCP.prm / MXF_DCP.bundle.
CuteDCPTools.aex: This is the After Effects main plug-in for CuteDCPTools
MXF_DCP.prm/.bundle: This is a mxf file reader format plug-in that allows users to view and hear the
content of the image and audio track files of the DCP.
Where are the plug-ins installed?
Windows:
CS6:
C:\Program Files\Adobe\Adobe After Effects CS6\Plug-ins
- CuteDCPTools.aex
C:\Program Files\Adobe\Common\Plug-ins\CS6\MediaCore
- MXF_DCP.prm
CC:
C:\Program Files\Adobe\Common\Plug-ins\7.0\MediaCore
- both
CC2014: C:\Program Files\Adobe\Common\Plug-ins\7.0\MediaCore
- both
CC2015: C:\Program Files\Adobe\Common\Plug-ins\7.0\MediaCore
- both
CC2017: C:\Program Files\Adobe\Common\Plug-ins\7.0\MediaCore
- both
Mac:
CS6:

/Applications/Adobe After Effects CS6/Plug-ins			
- CuteDCPTools.aex
/Library/Application Support/Adobe/Common/Plug-ins/CS6/MediaCore - MXF_DCP.bundle
CC:
/Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore - both
CC2014: /Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore - both
CC2015: /Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore - both
CC2017: /Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore - both
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4. Preferences

Setting up your preferences and authorize CuteDCPTools
1. Launch After Effects
2. Open the CuteDCP Preferences:
Win: Goto menu Edit->Preferences->CuteDCPTools Preferences
Mac: Goto menu After Effects->Preferences->CuteDCPTools Preferences

Viewing options: This section is used for how the imported track files in the DCP are going to be
viewed. All changes made in this section requires a restart of After Effects.
Enable color space conversion: Performs a reverse color space conversion from x’y’z’ to rec709.
Downmix surround sound to stereo: After Effects only supports stereo on the timeline. If your DCP
has surround sound you have the option to downmix all surround tracks to a stereo track.
Please note that this is only for previewing the audio, if the audio is re-wrapped using one of the
tools in CuteDCPTools, the number of audio tracks is untouched.
Stereoscopic display: Select how you want to view your stereoscopic image track file.
Issuer: Sets the issuer tag of the DCP, visible in cpl, pkl and ASSETMAP xml-files
Default LoadFont: If you are using subtitles or close captions and has a standard font that you are
using over and over again, you can select it here.
Enable Signing: When your Signer Certificates are properly setup (see below), you have the option to
sign your DCP. Signing a DCP grants that no one has altered the DCP in any way.
When creating an encrypted DCP this is a required option.
Clear cached keys: Removes all keys used for decryption.
About button: Opens up the About and Registration dialog.
Signer Certificate Setup: Opens the dialog for adding or creating certificates.

6

The About/Registration dialog

The About/Registration window

In the About dialog, you can view what version of CuteDCPTools you are using.
You can also unlock your purchased copy CuteDCPTools here.
Just add your name and the serial number you received when the purchase was completed.

Signer Certificate Setup dialog

In the “Signer Certificate Setup” dialog, add your existing certificates or create a new set of certificates
to be used for signing and encrypting your DCP. When using CuteDCPTools in **demo** mode, a set of
time limited demo certificates is created.
Create Certificates: Creates a new set of certificates.
Export Public Certificate: Exports the public certificate from your set of certificates. This exported
certificate could be used to create a DKDM (Distribution KDM) targeting your CuteDCPTools mastering
station. In other words, it would allow you to open an encrypted DCP created by someone else.
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5. ReMastering
- Example 1: Import a DCP and add subtitles -

1. Launch After Effects
2. Select the DCP you would like to import. From the menu select File->Import->CuteDCPTools Import DCP.

3. When the import is completed, you will see the following in the project panel.

This is the root folder of the DCP.
All assets that belongs to the DCP
are collected here. e.g. video and audio files.
This is the composition.
A DCP may have several compositions and each
composition could be a language adaptions with
differerent subtitles and/or audio tracks.
Make sure that the composition is properly named
and that it is following the naming convention.
http://digitalcinemanamingconvention.com

The Project panel

This subtype tells us what packing method that was used for packing video and audio files.
Note: Only visible on video tack files.
_iop: Interop packing was used.
iopE: Interop packing was used, encrypted file.
smpt: SMPTE packing was used.
smpE: SMPTE packing was used, encrypted file.

reel2
reel1
The Imported DCP in the timeline, this imported DCP has two reels.
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- Adding subtitles to the imported DCP 4. In the project panel, duplicate your composition. Select composition then goto menu Edit->Duplicate.
The duplicated composition is going to contain all your subtitles spots.
5. Select the duplicated composition and go to menu Composition->Composition Settings.
The name of my duplicated composition is:
HANS-GRETA_ADV_C_SV-XX_20_2K_20141119_SPO_OV 2
We will change the following:
Remove the number 2 at the end of the title, the number 2 tells us that it is a duplicate.
Change SV-XX to SV-EN.
SV means that we have swedish audio and XX that no subtitles is present.
So accordingly SV-EN means, swedish audio and english subtitles.
Your title should now look like this:
HANS-GRETA_ADV_C_SV-EN_20_2K_20141119_SPO_OV
Press OK.

6. It is now time to add subtitles to your composition and we are going to use one of the tools in the 		
CuteDCPTools toolkit. Select the newly re-named composition, then go to menu “File->Import->Cute
DCP Import Subtitles to Comp”. You will be prompted to browse and select a subtitle file.
CuteDCPTools supports Cinecanvas or SMPTE 428-7 subtitle files.
7. When the subtitle import progress is finished text layers are added to your composition.

The composition with added subtitles

8. When all subtitles are in place, it is time to re-package the DCP and export it all out again.

9. In the Project panel, select the root folder.
Go to menu “Export->CuteDCPTools RePackage DCP“
The RePackage DCP dialog is now open.
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- RePackage the DCP -

Overview: This window shows information
about the imported DCP and all the changes
that has been made to it, like adding subtitles.
Composition Content Titles: Shows all
available compositions in the DCP.
You can edit the titles directly in this view, just
simply double click on the content title you
want to edit.
It is these titles that will appear on the digital
cinema server.
Title Helper: You need to select the content
title in the view above that you want to edit,
when selected the Title Helper button is enabled and pressing this button brings up the
Title Helper Dialog. See page 12.

Packing Format: There are currently two digital cinema standards in the field – the older Interop
format is gradually being replaced by the more recent DCI SMPTE standard.
Interop only supports frame rates of 24fps and 48 fps for 3D content.
The newer SMPTE format supports a wide range of frame rates: 24, 25, 30, 48, 50 and 60 fps.
Category: Select the category of your DCP. This category will be visible in the cinema server.
Note: The category is automatically reflecting the category setting in the Title Helper.
Force Repacking: When enabled, you have the option to change packaging format, e.g. SMPTE to
Interop or vice versa. Note that this option is only available at 24fps.
Repackage trimmed layers: When enabled, all trimmed layers are re-packaged in to a new mxf
container. This is a nice feature if you want to make an excerpt from a DCP and only use the
selected frames to the new DCP.
Annotation text: If you have an annotation text describing the DCP, you can type it here. (optional)
Use LoadFont: When enabled, a LoadFont tag is added to the subtitle file with the selected font.
This is for subtitles only.
Signing and Encryption section:
Enable Signing: When selected, the DCP is signed using your certificates. If no certificates has been
added, the signing and encryption section is disabled
Repackage and Encrypt: If selected, the full DCP will be encrypted.
Storage file for Encryption Keys: The key storage file is the file that holds all keys used for encryption. It is important to store this file in a safe place, if lost, you will not be able to open your encrypted
file again. Note, this path is automatically filled out when setting the output path for the DCP and the
key storage file will be saved next to the DCP.
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Copy, move or leave assets: You have these options for the video and audio files from the original
DCP. The Move option, moves video and audio files to the new destination. When using the
“Move“ option, please note that the linkage to the imported video and audio files in After Effects
will be broken and After Effects will popup a warning message.
The copy option, copies video and audio files to the new destination. The leave option, leaves
video and audio files at the original DCP. This option is useful when making a VF (version file) of
the DCP.
Note that if your assets are being re-wrapped, you can see that in the overview window, none of
these actions is performed.
Output path: The destination path for the re-mastered DCP.

10. Select output path and make other optional changes, like setting an annotation text or changing the
category. The Export is enabled when an output path is present.
Press Export and the re-mastering process starts.
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- Title Helper Title Helper is a tool for creating properly formatted Content Titles, it will help you comply with the
Digital Cinema Naming Convention.
For those not familiar with the Naming Convention, it has two primary objectives:
1) to make as much information visible as possible, and
2) to display the information in a specific order, in assigned fields, so theatres will know where to look
for specific information. Most of the information in these fields is abbreviated, including the movie title
if necessary, and most of the abbreviations are standardized.
For more information about Digital Cinema Naming Convention, click here:
http://www.digitalcinemanamingconvention.com/

When checked, TitleHelper remembers this selection until you uncheck it or reset the panel.
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- Example 2: Rename a DCP If you have a DCP that is poorly named and doesn’t comply to the digital cinema naming convention,
you can easily rename the content titles with CuteDCPTools. The Title Helper tool helps you to make a
nicely formatted content title for the DCP.
A well formatted content title has a lot more information than just the title of the movie, and this extra
information is located in specified field and in a specific order
1. Import a DCP as shown in the previous chapter.
Goto to menu File->Import->CuteDCPTools Import DCP and select the DCP to be imported.

2. Here is the DCP that needs to be re-named.
Select the root folder as shown in the picture below.

3. Go to menu Export->CuteDCPTools RePackage DCP

Composition content titles view in the RePackage dialog

4. Select the composition to be re-named, click on the “Title Helper” button.
In the “Title Helper“ tool, use as many fields as possible to give the composition a well formatted
title. The more info you can add to the content title the better it is.
Please refer to http://digitalcinemanamingconvention.com for more info.
Click OK to set the name.
5. Select output path and make other optional changes, like setting an annotation text or changing the
category. The Export is enabled when an output path is present.
Press Export and the re-mastering process starts.
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6. Adding a reel to the DCP
- Example 3 Sometimes it is necessary to make modifications to the DCP, like adding a leading logo for a film
festival or adding a distributor logo at the end of the DCP.
Instead of re-encoding the whole film from scratch again you can add a leading or trailing reel or
both to your existing DCP.
You can can think of reels like a playlist, first it plays reel 1 then reel 2.....etc.
In this example we are going to add a reel, showing the festival logo, at the beginning of the DCP.
1. Import a DCP as shown in the previous chapter.
Goto to menu File->Import->CuteDCPTools Import DCP and select the DCP to be imported.

The Imported DCP in the timeline, this imported DCP has only one reel.

2. Now, lets create a 5 sec DCP for the festival logo. Just fading up and then fading down.
Make sure that frame rate, frame size and packaging format matches the main DCP.
Then use your favorite DCP export application to create this small DCP.
3. Import the newly exported ‘Festival logo‘ DCP into After Effects.
4. Select the video and audio file from the festival logo DCP in
the project panel.
They are named here with j2c...mxf / pcm...mxf.
Drag them into the timeline for your main DCP.

The project window with the imported DCPs.

5. Now you have two reels on the timeline:
reel1– festival logo,
reel – the main DCP.
You also need to slip reel2 to the out point of reel 1 so that
the reels not are overlapping.

reel1
reel2
The final result.

6. It is time to re-package and export the modified DCP.
Select the root folder of the main DCP in the project window.
Go to File->Export->CuteDCPTools RePackage. In the RePackage dialog make any changes needed.
(Check other examples of what changes you can make)

14

7. Splitting a DCP in to reels
- Example 4 -

Why split a DCP into reels?
Well, there could be several reasons for that:
1. Easier to update the DCP.
2. Loads faster during ingest in to the cinema server.
3. Some cinema projectors needs subtitles to be split into reels because the lack of memory to store
the full subtitle track; you could experience intermittent missing subtitles spots.
The length of a reel in the old photochemical world was apprx. 20 min, for the new digital DCP world
the length are often the same.
However, splitting a digital feature into reels makes a lot of sense in terms of handling files and
making changes.
Where to split and not to split.
- Always split between scenes.
- Avoid splitting within a musical cue or a dialog
- If possible, no significant sound at the start of each new reel
- Each reel should be apprx. 20min

1. Import a DCP that you want to split into reels.
Goto to menu File->Import->CuteDCPTools Import DCP and select the DCP to be imported.

The Imported DCP in the timeline, this imported DCP has two reels.

2. Find appropriate split points as discussed above and split the video and audio layers into 20 min
chunks. Use the hot key cmd+Shift+D (Mac) or ctrl+Shift+D (Win) to split the layer or go to menu
Edit->Split Layer

The final result splitting the feature in to 5 reels.
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Example 4, continued.
3. Now it is time to re-package and export the splitted DCP.
Select the root folder of the main DCP in the project window.
Go to File->Export->CuteDCPTools RePackage.

4. Take a close look at the overview window and you will see that
all reels, video and audio tracks, are going to be re-wrapped in
new mxf containers.

5. In the RePackage dialog make any changes needed.
(Check other examples of what changes you can make)
6. Press Export button, CuteDCPTools now copies all frames from the original mxf-container to the
new mxf-containers, representing the reels.
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8. Updating audio files
- Example 5 In this example we are updating the audio track file using wave files.
From version 2.0, CuteDCPTools offers a simple way to update the audio track by re-wrapping the
mxf container from wave files.
After Effects only supports stereo audio from the timeline but with CuteDCPTools it is now possible to
map the files from the timeline into a new audio track files without doing any processing.
CuteDCPTools reads the audio samples directly from the wave files.
We are now going to replace a 5.1 audio mix with an updated audio mix.
1. Import the DCP that needs to be updated
2. Open the composition
3. Import the 5.1 surround mix.
The audio files must meet the following specification.
- Wave file (PCM)
- Mono files
- 48 kHz
- 24bit

The Imported 5.1 surround mix, 6 mono wave files.

4. Drag the audio files to the composition, for a 5.1 surround mix the channel order has to be the
following: Left - Right - Center - Sub - Left Surround - Right Surround
5. Don’t forget to delete the old audio track file.

The composition with the new surround mix

6. Select the root folder of the main DCP in the project window.
Go to File->Export->CuteDCPTools RePackage.
In the overview window you can see that the wave files needs to be wrapped.
7. Name the DCP and press Export.
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9. Update end credits in a DCP
- Example 6 In almost every film project late changes is something to count on, this also happens when the film is
mastered and the DCP has been encoded.
In this example you can deal with some changes without re-encode the complete DCP, the most common changes are updating end credits where typos, forgotten names and logos are the reason for that.
In this example we are going to update the end credits on a DCP
1. Import the DCP that we are going to update.
Goto to menu File->Import->CuteDCPTools Import DCP and select the DCP to be imported.

The Imported DCP contains 5 reels.

2. Like in a previous example we going to encode a small DCP of the updated end credits.
Use your favorite DCP export application to create the end credit DCP.
Make sure that frame rate, frame size and packaging format matches the main DCP.
3. Import the encoded end credits DCP into After Effects.
4. In the project panel, select the video file from the end credits
DCP and drag it into the timeline for your main DCP.
Make sure to match its in-point. It is a good idea to make a
note from what frame you did start the encoding.
5. Make sure that the added layer are within the in and out
point of the reel you want to update, if not, you will get an
error message and the re-mastering is aborted.
The project window with the updated end credits.

The final result.
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Example 6, continued.

6. Now it is time to export the re-mastered DCP.
Select the root folder of the main DCP in the project window.
Go to File->Export->CuteDCPTools RePackage.
In the RePackage dialog make any changes needed.
(Check other examples of what changes you can make)

7. Take a look in overview window and you will see that the video
track in the last reel will be merged with layer 1.

7. Press Export
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10. Subtitles/Closed Captions
With CuteDCPTools you have the possibility to import subtitles in to a composition or to export subtitles
from a composition to an interop subtitle file (Texas Instruments CineCanvas) or SMPTE 428-7 subtitle file.

Import subtitles dialog
Import Subtitles
Imports subtitles into an After Effects composition:
Goto menu File->Import->CuteDCPTools Import Subtitles to Comp

Subtitle type: Select subtitle type: Open Subtitles or Closed Captions.
Open Subtitles is visible for everybody in the audience.
Closed Captions is only possible view for people using a special Closed Captions device.
Language: Select the language of the imported subtitle file.
Frame Rate: Select the frame rate of the imported subtitle file.
Subtitle file: Select the subtitle file that you want to import.
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Export subtitles dialog
Export Subtitles
Exports subtitles from an After Effects composition:
Goto menu File->Export->CuteDCPTools Subtitle Export

Packaging: Select packaging format for the exported subtitle.
Content Title: Add a content title for the subtitle.
Annotation Text: Add an optional annotation text for the subtitle (SMPTE only).
Use LoadFont: Select a font to be used for the subtitle, optional for interop.
Output Path: Select output path for the exported subtitle.
21
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11. Encryption
- Example 7 - Encrypt a DCP To protect your film from unauthorized access, encryption is the ultimate way to go.
You decide which cinema who has right to show your film and for how long time.
The cinema that are going to show your film, gets a KDM (Key Delivery Message) which is a key to unlock the
encrypted DCP.
KDMs cannot be created within CuteDCPTools, Fandev has developed an external application for this purpose
called CuteKdmMaker
Follow the procedure as described in example 1 for importing a DCP
1. Launch After Effects
2. From the menu select File->Import->CuteDCPTools Import DCP, select the DCP you would like to import.
3. In the Project panel, select the root folder of the DCP you want to encrypt.
Go to menu “Export->CuteDCPTools RePackage DCP“
The RePackage DCP dialog is now open.

4. The first thing you need to do is to tick the “Enable
Signing“ checkbox. If this checkbox is disabled it has
to be enabled in the preferences first, See Preferences section.
5. Then tick “Repackage and Encrypt“ checkbox.
The “Storage File for Encryption keys“ text field will
automatically be filled out when setting the Output
path for the DCP. The default location for the KeyFile
is next to the Re-Mastered DCP.
If you prefer to store it somewhere else, you have the
possibility to browse and select a new location.
6. Press Export and the encryption process starts
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- Example 8 - Import an encrypted DCP
The procedure to import an encrypted DCP is almost identical to import an unencrypted DCP.
1. Launch After Effects
2. Select the DCP you would like to import. From the menu select File->Import->CuteDCPTools Import DCP.
3. If the importer detects that the DCP is encrypted, you will be asked how you want to decrypt it.

4. The importer looks by default for a “Key Storage File“ next to the DCP, if it is found, the key file path is automatically filled out and the Method: ‘Key‘ is selected .
5. The Method: ‘DKDM‘, (Distribution Key Delivery Message), is the second choice.
The difference between a DKDM and a KDM is that the DKDM is issued for DCP mastering system and a KDM is
issued for a cinema playback server, but structurally they are the same.
Mastering systems and cinema playback servers has certificates that identifies them, from these certificates a
DKDM or KDM could be issued.
6. Press OK and the DCP is imported.
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- Example 9 - Unencrypt a DCP To unencrypt a DCP is as simple as to encrypt it
1. Import an encrypted DCP, see previous example.
2. In the Project panel, select the root folder of the DCP you want to unencrypt.
Go to menu “Export->CuteDCPTools RePackage DCP“
The RePackage DCP dialog is now open.

3. Uncheck the “Repackage and Encrypt“ and you will get a warning saying:

4. Select your output path
5. Press Export and your unencrypt process starts.
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12. Moving the DCP to the cinema
Before copying your DCP to an external hard drive, make sure your external drive is formatted in one of the
following formats: NTFS, EXT2 or EXT3
NTFS is a Windows file system.
EXT2 & EXT3 are Linux file systems.
If your drive is Mac formatted (HFS/HFS+), the cinema server will not be able to read the drive.
Using FTP for delivery.
If you have a fast Internet connection and if the cinema or distributor has this service, this is a good option.
But there is one important thing to keep mind when uploading or downloading a DCP to/from a ftp server.
During the upload and download process, the line endings of the xml-files that are ASCII files could be
altered.
What you need to do is to change the transfer mode in your ftp application.
Ftp applications has different transfer modes, ASCII/Binary/Auto. “Auto” is mostly a default setting.
The “Auto” setting treats your xml-files as ASCII and video and audio files as binary
It is crucial to set the transfer mode to “Binary“, if not, xml-files are changed and results in bad signature
hash values; errors may occur during DCP ingest or playback.
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We welcome your feedback on CuteDCPTools
If you have any feedback, problems or questions, please contact us at:
info@fandev.com
For more DCP tutorials please visit: www.cutedcp.com

http://www.fandev.com
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